summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:10:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:34 +0200
commitbf5c92c6798fdb4688bf260258e4c6f110b4384b (patch)
treecf0bb214957e7727c670510873fb6591d130cbe7 /gnu
parent22f03ba5c6c2842ece551d8150ca9f585fdf50df (diff)
downloadguix-patches-bf5c92c6798fdb4688bf260258e4c6f110b4384b.tar
guix-patches-bf5c92c6798fdb4688bf260258e4c6f110b4384b.tar.gz
gnu: Add texlive-feynmf.
* gnu/packages/tex.scm (texlive-feynmf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4ecda4ecb2..f4be064c39 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5151,6 +5151,29 @@ containing angles, circles, cylinders, cones and spheres, among other
things.")
(license license:gpl3+)))
+(define-public texlive-feynmf
+ (package
+ (name "texlive-feynmf")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/feynmf/" "metafont/feynmf/"
+ "metapost/feynmf/" "source/latex/feynmf/"
+ "tex/latex/feynmf/")
+ (base32
+ "1a6zhs4x6rkjl7vapc3y59hmrvmi570ji2bszpsk88w3fi8klckb")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/feynmf")
+ (synopsis "Macros and fonts for creating Feynman (and other) diagrams")
+ (description
+ "The @code{feynmf} package provides an interface to Metafont to use
+simple structure specifications to produce relatively complex diagrams. While
+the package was designed for Feynman diagrams, it could in principle be used
+for diagrams in graph and similar theories, where the structure is
+semi-algorithmically determined.")
+ (license license:gpl3+)))
+
(define-public texlive-filemod
(package
(name "texlive-filemod")