summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:09:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:34 +0200
commit22f03ba5c6c2842ece551d8150ca9f585fdf50df (patch)
tree4155e2470daacc74f92f519487ca60e6eefef00a /gnu
parent09e0b7fff5ec577e83bb5b2ab69391ecab256089 (diff)
downloadguix-patches-22f03ba5c6c2842ece551d8150ca9f585fdf50df.tar
guix-patches-22f03ba5c6c2842ece551d8150ca9f585fdf50df.tar.gz
gnu: Add texlive-featpost.
* gnu/packages/tex.scm (texlive-featpost): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8494776ff4..4ecda4ecb2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5131,6 +5131,26 @@ figures. It is written entirely in MetaPost, and does not therefore require
any post processing of the MetaPost output.")
(license license:gpl3+)))
+(define-public texlive-featpost
+ (package
+ (name "texlive-featpost")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/featpost/"
+ "metapost/featpost/")
+ (base32
+ "0a97syvr3vwpayhasb98ssvgwr99p13plrjnqb9ad24jd6srmmdg")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/featpost")
+ (synopsis "MetaPost macros for 3D")
+ (description
+ "These macros allow the production of three-dimensional schemes
+containing angles, circles, cylinders, cones and spheres, among other
+things.")
+ (license license:gpl3+)))
+
(define-public texlive-filemod
(package
(name "texlive-filemod")