summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-10-24 22:23:02 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-10-24 22:28:28 +0200
commitbe5216efcca161553fe474cf79155323bda06d91 (patch)
treea1e1c2121bc564b8218899d1a6f483a5f2036d09 /gnu
parent1636acaac500ce65249b49b97c06865deb1fb6b2 (diff)
downloadguix-patches-be5216efcca161553fe474cf79155323bda06d91.tar
guix-patches-be5216efcca161553fe474cf79155323bda06d91.tar.gz
gnu: python2-renpy: Update to 7.4.10.
* gnu/packages/game-development.scm (python2-renpy): Update to 7.4.10. [snippet]: No longer drop "gen" directory, it's not in this release.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/game-development.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index d66d46597d..c92d505ddb 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1239,21 +1239,19 @@ developed mainly for Ren'py.")
(define-public python2-renpy
(package
(name "python2-renpy")
- (version "7.4.8")
+ (version "7.4.10")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.renpy.org/dl/" version
"/renpy-" version "-source.tar.bz2"))
- (sha256 (base32 "1ml3gs87xxk1iflrg5ivffr4q8fi7d65l1cx462bvvpm1rs2sa8d"))
+ (sha256 (base32 "1yngs2kh1l8micg28mcp9580qsvgq3aa8bkhv2xqfkg9qqrbr8y4"))
(modules '((guix build utils)))
(patches
(search-patches
"renpy-use-system-fribidi.patch"))
(snippet
'(with-directory-excursion "module"
- ;; drop generated sources
- (delete-file-recursively "gen")
;; drop fribidi sources
(delete-file-recursively "fribidi-src")
#t))))