summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-11-24 10:43:02 +0200
committerEfraim Flashner <efraim@flashner.co.il>2015-11-25 20:42:06 +0200
commitbde2171d4daa09e86efc3352a9cc20def8dd9ac8 (patch)
tree069bbd6d8bfe66f89ad38240f447d985d743e803 /gnu
parent7957fe6c10820446a58d56a29dbcffc650557414 (diff)
downloadguix-patches-bde2171d4daa09e86efc3352a9cc20def8dd9ac8.tar
guix-patches-bde2171d4daa09e86efc3352a9cc20def8dd9ac8.tar.gz
gnu: python-oauthlib: Update to 1.0.3.
* gnu/packages/python.scm (python-oauthlib): Update to 1.0.3. [native-inputs]: Move python-setuptools, python-nose, python mock here. Add python-coverage. [inputs]: Add python-blinker, python-cryptography, python-pyjwt.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 94df2b6a90..f17185c345 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2185,23 +2185,23 @@ somewhat intelligeble.")
(define-public python-oauthlib
(package
(name "python-oauthlib")
- (version "0.6.3")
+ (version "1.0.3")
(source (origin
(method url-fetch)
- (uri
- (string-append
- "https://pypi.python.org/packages/source/o/oauthlib/oauthlib-"
- version ".tar.gz"))
+ (uri (pypi-uri "oauthlib" version))
(sha256
(base32
- "1yaj3j64la4arwsbhbfmpnickzh3jpg9nlpyg409v8pp24isn48a"))))
+ "1bfrj70vdjxjw74khbyh6f0dksv7p5rh2346jnlrffyacd3gwjzg"))))
(build-system python-build-system)
- (inputs
+ (native-inputs
`(("python-setuptools" ,python-setuptools)
- ("python-pyjwt" ,python-pyjwt)
- ("python-pycrypto" ,python-pycrypto)
+ ("python-coverage", python-coverage)
("python-nose" ,python-nose)
("python-mock" ,python-mock)))
+ (inputs
+ `(("python-blinker" ,python-blinker)
+ ("python-cryptography" ,python-cryptography)
+ ("python-pyjwt" ,python-pyjwt)))
(home-page "https://github.com/idan/oauthlib")
(synopsis "OAuth implementation for Python")
(description