summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 18:45:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:30 +0200
commitb853941a622e6c72dd1dcc6c79db2f9a570d523b (patch)
tree984f88a4edee546857a186d57ef3c87658ea9941 /gnu
parent2d48e1a18b8d64d2fd05aa800f7d905446b0dae4 (diff)
downloadguix-patches-b853941a622e6c72dd1dcc6c79db2f9a570d523b.tar
guix-patches-b853941a622e6c72dd1dcc6c79db2f9a570d523b.tar.gz
gnu: Add texlive-collection-context.
* gnu/packages/tex.scm (texlive-collection-context): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 852727a483..1a53979f82 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12128,6 +12128,56 @@ macros, Computer Modern fonts, and configuration for common drivers; no
LaTeX.")
(license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+(define-public texlive-collection-context
+ (package
+ (name "texlive-collection-context")
+ (version (number->string %texlive-revision))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments (list #:builder #~(mkdir #$output)))
+ (propagated-inputs
+ (list texlive-collection-basic
+ texlive-context
+ texlive-context-account
+ texlive-context-algorithmic
+ texlive-context-animation
+ texlive-context-annotation
+ texlive-context-bnf
+ texlive-context-chromato
+ texlive-context-cmscbf
+ texlive-context-cmttbf
+ texlive-context-construction-plan
+ texlive-context-cyrillicnumbers
+ texlive-context-degrade
+ texlive-context-fancybreak
+ texlive-context-filter
+ texlive-context-french
+ texlive-context-fullpage
+ texlive-context-gantt
+ texlive-context-gnuplot
+ texlive-context-handlecsv
+ texlive-context-layout
+ texlive-context-letter
+ texlive-context-lettrine
+ texlive-context-mathsets
+ texlive-context-rst
+ texlive-context-ruby
+ texlive-context-simplefonts
+ texlive-context-simpleslides
+ texlive-context-title
+ texlive-context-transliterator
+ texlive-context-typearea
+ texlive-context-typescripts
+ texlive-context-vim
+ texlive-context-visualcounter
+ texlive-jmn))
+ (home-page "https://www.tug.org/texlive/")
+ (synopsis "ConTeXt and packages")
+ (description
+ "This package provides Hans Hagen's powerful ConTeXt system, along with
+third-party ConTeXt packages.")
+ (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
(define-public texlive-collection-fontsrecommended
(package
(name "texlive-collection-fontsrecommended")