summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-02-17 15:15:20 -0500
committerLeo Famulari <leo@famulari.name>2021-02-18 00:45:07 -0500
commitb1b8ac09d7862b4ddac8a9343ed0f044322623e4 (patch)
tree5faf1d24b18c153a4489262ce3e33a9cb18a1268 /gnu
parent27ae8da87e41b9e0bace62168191da171273b5f4 (diff)
downloadguix-patches-b1b8ac09d7862b4ddac8a9343ed0f044322623e4.tar
guix-patches-b1b8ac09d7862b4ddac8a9343ed0f044322623e4.tar.gz
gnu: linux-libre 5.4: Update to 5.4.99.
* gnu/packages/linux.scm (linux-libre-5.4-version): Update to 5.4.99. (linux-libre-5.4-pristine-source): Update hash. (deblob-scripts-5.4): Use linux-libre-5.4-version.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 72fcd14e1f..3346b94021 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -382,17 +382,15 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
-(define-public linux-libre-5.4-version "5.4.98")
+(define-public linux-libre-5.4-version "5.4.99")
(define deblob-scripts-5.4
(linux-libre-deblob-scripts
- ;; XXX While linux-libre.fsfla.org is offline, use the cached deblob
- ;; scripts for the previous version on ci.guix.gnu.org.
- "5.4.97"
+ linux-libre-5.4-version
(base32 "0q3gwf3b404brjld7aj9krzv0wdpzvs8fgy088ag7q106cwgqg8i")
(base32 "1xghbbnaisjd0k1klbyn1p7r6r4x5a1bpmkm56a3gh2zvw4s7mj8")))
(define-public linux-libre-5.4-pristine-source
(let ((version linux-libre-5.4-version)
- (hash (base32 "1ca6pn7pgb9pnlsc1wb6kny7lxjlnwv6ywwxfqrz3273zgb4i8l3")))
+ (hash (base32 "09qs6nqzq7hsaq928jvbri4nfjm0m6rf0lfx6vc30g95d4nd3njv")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.4)))