summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:17:18 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:38 +0200
commitb166b6f634208e77bf73107a6185efd96ab4a6c3 (patch)
tree0b5a41fa8e6076dfc15f661c99e91bdb64ef6bf6 /gnu
parenta56b0dbf43f3bbc05aa8387eb99bd0dd7998bc18 (diff)
downloadguix-patches-b166b6f634208e77bf73107a6185efd96ab4a6c3.tar
guix-patches-b166b6f634208e77bf73107a6185efd96ab4a6c3.tar.gz
gnu: Add texlive-metaplot.
* gnu/packages/tex.scm (texlive-metaplot): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e2fccd9b2b..e942762162 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5514,6 +5514,30 @@ matrices, and many other things. It more or less contains @code{boxes.mp} and
@code{rboxes.mp}. It is easily extensible with new objects.")
(license license:lppl)))
+(define-public texlive-metaplot
+ (package
+ (name "texlive-metaplot")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/metaplot/" "metapost/metaplot/")
+ (base32
+ "19y8lj28gvky7f7g2i562ixwvmnxnflnfc8l8r0x7zg384hg8835")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/metaplot")
+ (synopsis "Plot-manipulation macros for use in MetaPost")
+ (description
+ "MetaPlot is a set of MetaPost macros for manipulating pre-generated
+plots (and similar objects), and formatting them for inclusion in a MetaPost
+figure. The intent is that the plots can be generated by some outside
+program, in an abstract manner that does not require making decisions about
+on-page sizing and layout, and then they can be imported into MetaPlot and
+arranged using the full capabilities of MetaPost. Metaplot also includes
+a very flexible set of macros for generating plot axes, which may be useful in
+other contexts as well.")
+ (license license:lppl)))
+
(define-public texlive-natbib
(package
(name "texlive-natbib")