summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:16:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:37 +0200
commita56b0dbf43f3bbc05aa8387eb99bd0dd7998bc18 (patch)
treee1eca4979148b15d31a6c4451b23e4b7852e10fb /gnu
parentd05109ca2c31633d9b957b11cfbb17f5a068f1ea (diff)
downloadguix-patches-a56b0dbf43f3bbc05aa8387eb99bd0dd7998bc18.tar
guix-patches-a56b0dbf43f3bbc05aa8387eb99bd0dd7998bc18.tar.gz
gnu: Add texlive-metaobj.
* gnu/packages/tex.scm (texlive-metaobj): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 72303d6e29..e2fccd9b2b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5494,6 +5494,26 @@ methods of usage are provided, either using the package programmatically, or
using the package via a script (which may produce several images).")
(license license:lppl)))
+(define-public texlive-metaobj
+ (package
+ (name "texlive-metaobj")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/metaobj/" "metapost/metaobj/")
+ (base32
+ "1ir6p14h79x5iqbxmj2893x8j1d490bnhs83jwnrbcjxn0yxky6w")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/metaobj")
+ (synopsis "MetaPost package providing high-level objects")
+ (description
+ "METAOBJ is a large MetaPost package providing high-level objects. It
+implements many of PSTricks features for node connections, but also trees,
+matrices, and many other things. It more or less contains @code{boxes.mp} and
+@code{rboxes.mp}. It is easily extensible with new objects.")
+ (license license:lppl)))
+
(define-public texlive-natbib
(package
(name "texlive-natbib")