summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-07-24 09:01:40 -0300
committerMarius Bakke <marius@gnu.org>2020-07-25 18:47:57 +0200
commit9c4d0d29a25def622ff2020ca472d464259cff13 (patch)
treed1899aad699b9f56aa0e2d45574bd8ec6f5d573f /gnu
parentea4972e6dc1bdda288bebb120a07546fa915f133 (diff)
downloadguix-patches-9c4d0d29a25def622ff2020ca472d464259cff13.tar
guix-patches-9c4d0d29a25def622ff2020ca472d464259cff13.tar.gz
gnu: Add python-cfgv.
* gnu/packages/python-xyz.scm (python-cfgv): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 22b2c6b4e9..a2ec1fc88c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17578,6 +17578,38 @@ Let's Encrypt.")
(define-public python2-dns-lexicon
(package-with-python2 python-dns-lexicon))
+(define-public python-cfgv
+ (package
+ (name "python-cfgv")
+ (version "3.1.0")
+ (source
+ (origin
+ ;; There are no tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/asottile/cfgv")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vvkkqw92sak4b28bpscpppq483amy52ch2yqy1i2m23q7xjkabx"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-covdefaults" ,python-covdefaults)
+ ("python-coverage" ,python-coverage)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/asottile/cfgv")
+ (synopsis "Configuration validation library")
+ (description
+ "This library helps to validate configuration files and produce human
+readable error messages.")
+ (license license:expat)))
+
(define-public python-commandlines
(package
(name "python-commandlines")