summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-07-24 09:01:39 -0300
committerMarius Bakke <marius@gnu.org>2020-07-25 18:47:56 +0200
commitea4972e6dc1bdda288bebb120a07546fa915f133 (patch)
treea741e6c1a3cb1cf72d73b059c0e533d74023a3a6 /gnu
parent8ea5d35e5c96a8eba931b22d6318b542b74172ff (diff)
downloadguix-patches-ea4972e6dc1bdda288bebb120a07546fa915f133.tar
guix-patches-ea4972e6dc1bdda288bebb120a07546fa915f133.tar.gz
gnu: Add python-covdefaults.
* gnu/packages/python-check.scm (python-covdefaults): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 687fe2c778..f71eef0c92 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -311,6 +311,37 @@ internet.")
in Pytest.")
(license license:bsd-3)))
+(define-public python-covdefaults
+ (package
+ (name "python-covdefaults")
+ (version "1.1.0")
+ (source
+ (origin
+ ;; The PyPI tarball does not include tests.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/asottile/covdefaults")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11a24c0wzv01n55fy4kdpnyqna4m9k0mp58kmhiaks34xw4k37hq"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/asottile/covdefaults")
+ (synopsis "Coverage plugin to provide opinionated default settings")
+ (description
+ "Covdefaults is a coverage plugin to provide opinionated default
+ settings.")
+ (license license:expat)))
+
(define-public python-pytest-vcr
;; This commit fixes integration with pytest-5
(let ((commit "4d6c7b3e379a6a7cba0b8f9d20b704dc976e9f05")