summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-12 18:19:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:34 +0200
commit9bfa1ca1c24ff3386f040b517b414475a101bbdf (patch)
tree1aa99e628bda079971b5b39a9d5b0394f81621e7 /gnu
parent01330385f80345c4cfb6e063f20e579a84bd64a4 (diff)
downloadguix-patches-9bfa1ca1c24ff3386f040b517b414475a101bbdf.tar
guix-patches-9bfa1ca1c24ff3386f040b517b414475a101bbdf.tar.gz
gnu: Add texlive-breakurl.
* gnu/packages/tex.scm (texlive-breakurl): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0e3d60e62d..502b807674 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12359,6 +12359,30 @@ also contains the @code{flexisym} and @code{mathstyle} packages, which are
both designated as support for @code{breqn}.")
(license license:lppl1.3+))))
+(define-public texlive-breakurl
+ (package
+ (name "texlive-breakurl")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/breakurl/" "source/latex/breakurl/"
+ "tex/latex/breakurl/")
+ (base32
+ "1lihfrihf1i300sddz09rsn6gj30g299warn88gli9hbrfy6nvw5")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-iftex texlive-latex-xkeyval))
+ (home-page "https://ctan.org/pkg/breakurl")
+ (synopsis "Line-breakable links in @code{hyperref} for dvips/ps2pdf")
+ (description
+ "This package provides a command much like @code{hyperref}'s @code{\\url}
+that typesets a URL using a typewriter-like font. However, if the dvips
+driver is being used, the original @code{\\url} doesn't allow line breaks in
+the middle of the created link: the link comes in one atomic piece. This
+package allows such line breaks in the generated links.")
+ (license license:lppl)))
+
(define-public texlive-comment
(package
(inherit (simple-texlive-package