summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-09 22:45:04 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:33 +0200
commit01330385f80345c4cfb6e063f20e579a84bd64a4 (patch)
treeb76af99d6c90a42a7a6fb1c51b3dffec41c24fde /gnu
parentf36563c7b39154558b5fd61deded0be37e1d2f8e (diff)
downloadguix-patches-01330385f80345c4cfb6e063f20e579a84bd64a4.tar
guix-patches-01330385f80345c4cfb6e063f20e579a84bd64a4.tar.gz
gnu: Add texlive-euenc.
* gnu/packages/tex.scm (texlive-euenc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2ec4bbe5d8..0e3d60e62d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11339,6 +11339,35 @@ styles of inference rules, placement of labels, etc.")
sequent calculus and related systems.")
(license license:lppl1.3+))))
+(define-public texlive-euenc
+ (package
+ (name "texlive-euenc")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/euenc/" "source/latex/euenc/"
+ "tex/latex/euenc/")
+ (base32
+ "0vhqxhj1v68rhi08xivps8icxmlcq9mv8slqmsmf2qhvzj6x6qx3")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ ;; Sole ".dtx" file bundled only generates documentation.
+ (list #:build-targets #~(list)))
+ (home-page "https://ctan.org/pkg/euenc")
+ (synopsis "Unicode font encoding definitions for XeTeX")
+ (description
+ "The package provides font encoding definitions for unicode fonts loaded
+by LaTeX in XeTeX or LuaTeX. The package provides two encodings: EU1,
+designed for use with XeTeX, which the fontspec uses for unicode fonts which
+require no macro-level processing for accents, and EU2, which provides the
+same facilities for use with LuaTeX. Neither encoding places any restriction
+on the glyphs provided by a font; use of EU2 causes the package
+@code{euxunicode} to be loaded (the package is part of this distribution).
+The package includes font definition files for use with the Latin Modern
+OpenType fonts.")
+ (license license:lppl1.3+)))
+
(define-public texlive-eurosym
(let ((template (simple-texlive-package
"texlive-eurosym"