summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 16:55:44 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:27 +0300
commit920c113f22c32fe8f5cebcfb04b6ca771c5b20f7 (patch)
treef4ce2d5c120cf5faf27be5c380e8139afcda5369 /gnu
parentd30ba2671bb75958abdccb8cec807cbff6f263fc (diff)
downloadguix-patches-920c113f22c32fe8f5cebcfb04b6ca771c5b20f7.tar
guix-patches-920c113f22c32fe8f5cebcfb04b6ca771c5b20f7.tar.gz
gnu: Add gopkg-in-errgo-fmt-errors.
* gnu/packages/golang.scm (gopkg-in-errgo-fmt-errors): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a0e6851fd5..ea7a6f19db 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5602,3 +5602,31 @@ Included are the following:
@item txtar: simple text-based file archives for testing.
@end itemize\n")
(license license:bsd-3)))
+
+(define-public gopkg-in-errgo-fmt-errors
+ (package
+ (name "gopkg-in-errgo-fmt-errors")
+ (version "2.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-errgo/errgo")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "065mbihiy7q67wnql0bzl9y1kkvck5ivra68254zbih52jxwrgr2"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "gopkg.in/errgo.v2/fmt/errors"
+ #:tests? #f
+ ;; Source-only package
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'build))))
+ (home-page "https://godoc.org/gopkg.in/errgo.v2")
+ (synopsis "Functions that use the fmt package to format error messages")
+ (description "This package is the same as @code{gopkg.in/errgo.v2/errors}
+except that it adds convenience functions that use the fmt package to format
+error messages.")
+ (license license:bsd-3)))