summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-09 22:27:31 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-11 01:14:36 +0100
commit91304b79453440a90c366cb667a19d91eb5752e2 (patch)
tree22723c8348b7ac607dd8b495f73a0f173efe7811 /gnu
parent8d9d6adbab6cb21b44f86ab445ad60f8c115249b (diff)
downloadguix-patches-91304b79453440a90c366cb667a19d91eb5752e2.tar
guix-patches-91304b79453440a90c366cb667a19d91eb5752e2.tar.gz
gnu: mesa: Update to 19.2.7.
* gnu/packages/patches/mesa-timespec-test-32bit.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gl.scm (mesa): Update to 19.2.7. [source](patches): Remove obsolete.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gl.scm7
-rw-r--r--gnu/packages/patches/mesa-timespec-test-32bit.patch17
3 files changed, 3 insertions, 22 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 0faa0ba07c..a76f222abd 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1136,7 +1136,6 @@ dist_patch_DATA = \
%D%/packages/patches/mcrypt-CVE-2012-4527.patch \
%D%/packages/patches/mes-remove-store-name.patch \
%D%/packages/patches/mesa-skip-disk-cache-test.patch \
- %D%/packages/patches/mesa-timespec-test-32bit.patch \
%D%/packages/patches/mescc-tools-boot.patch \
%D%/packages/patches/meson-for-build-rpath.patch \
%D%/packages/patches/metabat-fix-compilation.patch \
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index a1350be26a..6423a61f34 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -229,7 +229,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "19.2.1")
+ (version "19.2.7")
(source
(origin
(method url-fetch)
@@ -241,10 +241,9 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "1s81kwcjkkahnf5y5mshmd3q9j057hhsai7awpq6yb6im2hkriac"))
+ "17jp8ghipgz62vqqz5llskxypkcmgf8gnlgnj0pyvnbgi6vryyg3"))
(patches
- (search-patches "mesa-skip-disk-cache-test.patch"
- "mesa-timespec-test-32bit.patch"))))
+ (search-patches "mesa-skip-disk-cache-test.patch"))))
(build-system meson-build-system)
(propagated-inputs
`(;; The following are in the Requires.private field of gl.pc.
diff --git a/gnu/packages/patches/mesa-timespec-test-32bit.patch b/gnu/packages/patches/mesa-timespec-test-32bit.patch
deleted file mode 100644
index 3e4890f3a4..0000000000
--- a/gnu/packages/patches/mesa-timespec-test-32bit.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Fix a test failure on 32-bit systems.
-
-Taken from upstream:
-https://gitlab.freedesktop.org/mesa/mesa/commit/dd1dba80b9ee74ec8b90761285a8262e374bf8ef
-
-diff --git a/src/util/tests/timespec/timespec_test.cpp b/src/util/tests/timespec/timespec_test.cpp
---- a/src/util/tests/timespec/timespec_test.cpp
-+++ b/src/util/tests/timespec/timespec_test.cpp
-@@ -206,7 +206,7 @@ TEST(timespec_test, timespec_from_nsec)
-
- timespec_from_nsec(&a, UINT64_MAX);
- EXPECT_EQ(a.tv_nsec, UINT64_MAX % NSEC_PER_SEC);
-- EXPECT_EQ(a.tv_sec, UINT64_MAX / NSEC_PER_SEC);
-+ EXPECT_EQ(a.tv_sec, (time_t)(UINT64_MAX / NSEC_PER_SEC));
- }
-
- TEST(timespec_test, timespec_from_usec)