summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mesa-timespec-test-32bit.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/mesa-timespec-test-32bit.patch')
-rw-r--r--gnu/packages/patches/mesa-timespec-test-32bit.patch17
1 files changed, 0 insertions, 17 deletions
diff --git a/gnu/packages/patches/mesa-timespec-test-32bit.patch b/gnu/packages/patches/mesa-timespec-test-32bit.patch
deleted file mode 100644
index 3e4890f3a4..0000000000
--- a/gnu/packages/patches/mesa-timespec-test-32bit.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Fix a test failure on 32-bit systems.
-
-Taken from upstream:
-https://gitlab.freedesktop.org/mesa/mesa/commit/dd1dba80b9ee74ec8b90761285a8262e374bf8ef
-
-diff --git a/src/util/tests/timespec/timespec_test.cpp b/src/util/tests/timespec/timespec_test.cpp
---- a/src/util/tests/timespec/timespec_test.cpp
-+++ b/src/util/tests/timespec/timespec_test.cpp
-@@ -206,7 +206,7 @@ TEST(timespec_test, timespec_from_nsec)
-
- timespec_from_nsec(&a, UINT64_MAX);
- EXPECT_EQ(a.tv_nsec, UINT64_MAX % NSEC_PER_SEC);
-- EXPECT_EQ(a.tv_sec, UINT64_MAX / NSEC_PER_SEC);
-+ EXPECT_EQ(a.tv_sec, (time_t)(UINT64_MAX / NSEC_PER_SEC));
- }
-
- TEST(timespec_test, timespec_from_usec)