summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:26:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:43 +0200
commit8f29ad5791f8f388ecfec40d9fc06a20e93d8441 (patch)
tree3431d6da5938a51fbe17a491e676f34e581a2970 /gnu
parentc38de584f12b39059a3fb515296bbd3b49ae1aaa (diff)
downloadguix-patches-8f29ad5791f8f388ecfec40d9fc06a20e93d8441.tar
guix-patches-8f29ad5791f8f388ecfec40d9fc06a20e93d8441.tar.gz
gnu: Add texlive-roex.
* gnu/packages/tex.scm (texlive-roex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cf5f64a110..e11a0476c8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6049,6 +6049,29 @@ functions (curves, tangents, integrals, sequences) statistic diagrams plane
geometry (polygons, circles), arrays and game boards.")
(license license:lppl1.3c)))
+(define-public texlive-roex
+ (package
+ (name "texlive-roex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "metafont/roex/" "source/metafont/roex/")
+ (base32
+ "12w5wrrlk8rd4gx57646r01rb49ckmgnzhmx9385ll0sag8c9s2v")))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/mf-ps")
+ (synopsis "Metafont-PostScript conversions")
+ (description
+ "This package provides a Metafont support package including: @code{epstomf},
+a tiny AWK script for converting EPS files into Metafont; @code{mftoeps} for
+generating (encapsulated) PostScript files readable, e.g., by CorelDRAW, Adobe
+Illustrator and Fontographer; a collection of routines (in folder progs) for
+converting Metafont-coded graphics into encapsulated PostScript; and
+@code{roex.mf}, which provides Metafont macros for removing overlaps and
+expanding strokes. In @code{mftoeps}, Metafont writes PostScript code to
+a log-file, from which it may be extracted by either TeX or AWK.")
+ (license license:public-domain)))
+
(define-public texlive-selinput
(package
(name "texlive-selinput")