summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-07-12 22:25:30 +0200
committerLudovic Courtès <ludo@gnu.org>2013-07-12 22:25:30 +0200
commit8e5e7299d190e10238e020e36f4b1c036f32d949 (patch)
treeed8f25a87d77f50f0dd3b224c25345721f8be644 /gnu
parentf50ad3e7773cf0b0c46f10131c5b73d5f4478c14 (diff)
downloadguix-patches-8e5e7299d190e10238e020e36f4b1c036f32d949.tar
guix-patches-8e5e7299d190e10238e020e36f4b1c036f32d949.tar.gz
gnu: plotutils: Allow compilation with newer libpng.
* gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/patches/plotutils-libpng-jmpbuf.patch: New file. * gnu/packages/plotutils.scm (plotutils): Add `plotutils-libpng-jmpbuf.patch' as an input, and apply it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/plotutils-libpng-jmpbuf.patch23
-rw-r--r--gnu/packages/plotutils.scm8
2 files changed, 29 insertions, 2 deletions
diff --git a/gnu/packages/patches/plotutils-libpng-jmpbuf.patch b/gnu/packages/patches/plotutils-libpng-jmpbuf.patch
new file mode 100644
index 0000000000..07ef60996c
--- /dev/null
+++ b/gnu/packages/patches/plotutils-libpng-jmpbuf.patch
@@ -0,0 +1,23 @@
+Use the `png_jmpbuf' accessor, as recommended since libpng 1.4.0:
+http://www.libpng.org/pub/png/src/libpng-1.2.x-to-1.4.x-summary.txt .
+
+--- plotutils-2.6/libplot/z_write.c 2013-07-12 17:19:12.000000000 +0200
++++ plotutils-2.6/libplot/z_write.c 2013-07-12 17:19:07.000000000 +0200
+@@ -164,7 +164,7 @@ _pl_z_maybe_output_image (S___(Plotter *
+ }
+
+ /* cleanup after libpng errors (error handler does a longjmp) */
+- if (setjmp (png_ptr->jmpbuf))
++ if (setjmp (png_jmpbuf (png_ptr)))
+ {
+ png_destroy_write_struct (&png_ptr, (png_info **)NULL);
+ return -1;
+@@ -444,7 +444,7 @@ _our_error_fn_stdio (png_struct *png_ptr
+ #endif
+ }
+
+- longjmp (png_ptr->jmpbuf, 1);
++ longjmp (png_jmpbuf (png_ptr), 1);
+ }
+
+ static void
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 3080d74c4c..a3c43d79ba 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -22,7 +22,8 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages xorg)
- #:use-module (gnu packages libpng))
+ #:use-module (gnu packages libpng)
+ #:use-module (gnu packages))
(define-public plotutils
(package
@@ -36,10 +37,13 @@
(base32
"1arkyizn5wbgvbh53aziv3s6lmd3wm9lqzkhxb3hijlp1y124hjg"))))
(build-system gnu-build-system)
+ (arguments '(#:patches (list (assoc-ref %build-inputs "patch/jmpbuf"))))
(inputs `(("libpng" ,libpng)
("libx11" ,libx11)
("libxt" ,libxt)
- ("libxaw" ,libxaw)))
+ ("libxaw" ,libxaw)
+ ("patch/jmpbuf"
+ ,(search-patch "plotutils-libpng-jmpbuf.patch"))))
(home-page
"http://www.gnu.org/software/plotutils/")
(synopsis "Plotting utilities and library")