summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/plotutils-libpng-jmpbuf.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/plotutils-libpng-jmpbuf.patch')
-rw-r--r--gnu/packages/patches/plotutils-libpng-jmpbuf.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/patches/plotutils-libpng-jmpbuf.patch b/gnu/packages/patches/plotutils-libpng-jmpbuf.patch
new file mode 100644
index 0000000000..07ef60996c
--- /dev/null
+++ b/gnu/packages/patches/plotutils-libpng-jmpbuf.patch
@@ -0,0 +1,23 @@
+Use the `png_jmpbuf' accessor, as recommended since libpng 1.4.0:
+http://www.libpng.org/pub/png/src/libpng-1.2.x-to-1.4.x-summary.txt .
+
+--- plotutils-2.6/libplot/z_write.c 2013-07-12 17:19:12.000000000 +0200
++++ plotutils-2.6/libplot/z_write.c 2013-07-12 17:19:07.000000000 +0200
+@@ -164,7 +164,7 @@ _pl_z_maybe_output_image (S___(Plotter *
+ }
+
+ /* cleanup after libpng errors (error handler does a longjmp) */
+- if (setjmp (png_ptr->jmpbuf))
++ if (setjmp (png_jmpbuf (png_ptr)))
+ {
+ png_destroy_write_struct (&png_ptr, (png_info **)NULL);
+ return -1;
+@@ -444,7 +444,7 @@ _our_error_fn_stdio (png_struct *png_ptr
+ #endif
+ }
+
+- longjmp (png_ptr->jmpbuf, 1);
++ longjmp (png_jmpbuf (png_ptr), 1);
+ }
+
+ static void