summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:16:10 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:37 +0200
commit8a03984e454df5498dde7b38880168f20a438f1d (patch)
tree83552b94ec2dcf061c24e9d8b913a529fb093ea4 /gnu
parent59412fc426baa5488874585d32bfb461d0796403 (diff)
downloadguix-patches-8a03984e454df5498dde7b38880168f20a438f1d.tar
guix-patches-8a03984e454df5498dde7b38880168f20a438f1d.tar.gz
gnu: Add texlive-mcf2graph.
* gnu/packages/tex.scm (texlive-mcf2graph): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 73c8b23dd3..47976cfe50 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5456,6 +5456,25 @@ is much more flexible, since it can be used as direct replacement for
provided by @code{tex.mp}.")
(license license:public-domain)))
+(define-public texlive-mcf2graph
+ (package
+ (name "texlive-mcf2graph")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/mcf2graph/")
+ (base32
+ "1pji3d2mllfi74kalvs11h7yy3hkm5g5nlmcpq2vn7cxjbaqk9sq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/mcf2graph")
+ (synopsis "Draw chemical structure diagrams with MetaPost")
+ (description
+ "The Molecular Coding Format (MCF) is a linear notation for describing
+chemical structure diagrams. This package converts MCF to graphic files using
+MetaPost.")
+ (license license:expat)))
+
(define-public texlive-natbib
(package
(name "texlive-natbib")