summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:15:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:36 +0200
commit59412fc426baa5488874585d32bfb461d0796403 (patch)
tree77c9a0d1161ca5507b96fab5bdc00bfcb2c1d321 /gnu
parent22c8a01a8d1e98b446bf4987a456860558bcb3aa (diff)
downloadguix-patches-59412fc426baa5488874585d32bfb461d0796403.tar
guix-patches-59412fc426baa5488874585d32bfb461d0796403.tar.gz
gnu: Add texlive-latexmp.
* gnu/packages/tex.scm (texlive-latexmp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8637eb0f99..73c8b23dd3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5433,6 +5433,29 @@ between various classes of Unix systems.")
(define-deprecated-package texlive-latex-ifplatform texlive-ifplatform)
+(define-public texlive-latexmp
+ (package
+ (name "texlive-latexmp")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/latexmp/" "metapost/latexmp/")
+ (base32
+ "1zxwxss5sl16laaqalr8043wmyk2bhlja3al5xlxkizvlnflqy0f")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/latexmp")
+ (synopsis "Interface for LaTeX-based typesetting in MetaPost")
+ (description
+ "The MetaPost package @code{latexMP} implements a user-friendly interface
+to access LaTeX-based typesetting capabilities in MetaPost. The text to be
+typeset is given as string. This allows even dynamic text elements, for
+example counters, to be used in labels. Compared to other implementations it
+is much more flexible, since it can be used as direct replacement for
+@code{btex.etex}, and much faster, compared for example to the solution
+provided by @code{tex.mp}.")
+ (license license:public-domain)))
+
(define-public texlive-natbib
(package
(name "texlive-natbib")