summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:05:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:32 +0200
commit8210579aaace3a9a5b0b780d1691bd4a028ca471 (patch)
tree5b8edb65e080e8160bc6192f6b2b2c5fd521362f /gnu
parent33e3880687ea0c0589c6dd19f7842879839cd9ec (diff)
downloadguix-patches-8210579aaace3a9a5b0b780d1691bd4a028ca471.tar
guix-patches-8210579aaace3a9a5b0b780d1691bd4a028ca471.tar.gz
gnu: Add texlive-bpolynomial.
* gnu/packages/tex.scm (texlive-bpolynomial): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2f6a066590..3f916591de 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4216,6 +4216,28 @@ diagrams and bond graphs. While the task is not itself difficult to program,
it is felt that many users will be happy to have a library for the job.")
(license license:lppl)))
+(define-public texlive-bpolynomial
+ (package
+ (name "texlive-bpolynomial")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/bpolynomial/"
+ "metapost/bpolynomial/")
+ (base32
+ "1p4c3xc55zij85yy1jhmj7jrkxss935qx5zdxbm79mjlxx1aq1q0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/bpolynomial")
+ (synopsis "Drawing polynomial functions of up to order 3")
+ (description
+ "This MetaPost package helps plotting polynomial and root functions up to
+order three. The package provides macros to calculate Bezier curves exactly
+matching a given constant, linear, quadratic or cubic polynomial, or square or
+cubic root function. In addition, tangents on all functions and derivatives
+of polynomials can be calculated.")
+ (license license:lppl)))
+
(define-public texlive-cmexb
(package
(name "texlive-cmexb")