summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:05:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:31 +0200
commit33e3880687ea0c0589c6dd19f7842879839cd9ec (patch)
tree8f2b0296c789c407e5723a69273a6ae358cd9a44 /gnu
parent78ccd513fefc46077d752284381d3504fe2def1d (diff)
downloadguix-patches-33e3880687ea0c0589c6dd19f7842879839cd9ec.tar
guix-patches-33e3880687ea0c0589c6dd19f7842879839cd9ec.tar.gz
gnu: Add texlive-blockdraw-mp.
* gnu/packages/tex.scm (texlive-blockdraw-mp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dda18ae7cc..2f6a066590 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4196,6 +4196,26 @@ change the typography of the bibliographies.")
sorts with MetaPost.")
(license license:public-domain)))
+(define-public texlive-blockdraw-mp
+ (package
+ (name "texlive-blockdraw-mp")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/blockdraw_mp/"
+ "metapost/blockdraw_mp/")
+ (base32
+ "1z0cgjslx4kx8fspf3i5h4idxlzhgpm14i16vq88c96z8cdjb2xy")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/blockdraw_mp")
+ (synopsis "Block diagrams and bond graphs, with MetaPost")
+ (description
+ "This package provides a set of simple MetaPost macros to draw block
+diagrams and bond graphs. While the task is not itself difficult to program,
+it is felt that many users will be happy to have a library for the job.")
+ (license license:lppl)))
+
(define-public texlive-cmexb
(package
(name "texlive-cmexb")