summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-06-16 21:01:36 -0700
committerEfraim Flashner <efraim@flashner.co.il>2020-07-09 17:00:22 +0300
commit7ed3dc65c46119bfc92870312fca6f635ec3d7f7 (patch)
tree1ec6f195f1d259d586dc08fe7255de118b26be1e /gnu
parent51d44ede6c5eba6104b2873b81f74dedf225276e (diff)
downloadguix-patches-7ed3dc65c46119bfc92870312fca6f635ec3d7f7.tar
guix-patches-7ed3dc65c46119bfc92870312fca6f635ec3d7f7.tar.gz
gnu: Add rust-rustc-ap-rustc-index-654.
* gnu/packages/crates-io.scm (rust-rustc-ap-rustc-index-654): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8d8cf90470..b36b554d47 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -20253,6 +20253,34 @@ It is automatically published using the compiler repository at
@url{https://www.github.com/rust-lang/rust}")
(license (list license:expat license:asl2.0))))
+(define-public rust-rustc-ap-rustc-index-654
+ (package
+ (name "rust-rustc-ap-rustc-index")
+ (version "654.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rustc-ap-rustc_index" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0qqnvdn3zbwrn884ziw0nrmi1wqmr9yp8js7whw6y8nzdhz0q8ij"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-rustc-ap-serialize" ,rust-rustc-ap-serialize-654)
+ ("rust-smallvec" ,rust-smallvec-1))))
+ (home-page "https://github.com/alexcrichton/rustc-auto-publish")
+ (synopsis
+ "Automatically published version of the types of indexes in rustc")
+ (description
+ "Use the types of index used in the Rust compiler with this crate.
+It is automatically published using the compiler repository at
+@url{https://www.github.com/rust-lang/rust}")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-rustc-ap-rustc-lexer-654
(package
(name "rust-rustc-ap-rustc-lexer")