summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-06-16 20:52:14 -0700
committerEfraim Flashner <efraim@flashner.co.il>2020-07-09 17:00:22 +0300
commit51d44ede6c5eba6104b2873b81f74dedf225276e (patch)
tree5cdfc02473de53fef1f9f2b2b7af88328f853f7b /gnu
parent5850a02185c8d72bdce0ba09d67f54be02686cf0 (diff)
downloadguix-patches-51d44ede6c5eba6104b2873b81f74dedf225276e.tar
guix-patches-51d44ede6c5eba6104b2873b81f74dedf225276e.tar.gz
gnu: Add rust-rustc-ap-serialize-654.
* gnu/packages/crates-io.scm (rust-rustc-ap-serialize-654): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index efd3c09db1..8d8cf90470 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -20307,6 +20307,34 @@ It is automatically published using the compiler repository at
@url{https://www.github.com/rust-lang/rust}.")
(license (list license:expat license:asl2.0))))
+(define-public rust-rustc-ap-serialize-654
+ (package
+ (name "rust-rustc-ap-serialize")
+ (version "654.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rustc-ap-serialize" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vwfa3q4f9k0nfryr53jnwmf8vhaq7ijbgw8449nx467dr98yvkm"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-indexmap" ,rust-indexmap-1)
+ ("rust-smallvec" ,rust-smallvec-1))))
+ (home-page "https://github.com/alexcrichton/rustc-auto-publish")
+ (synopsis
+ "Automatically published versions of the serialize crate used in rustc")
+ (description
+ "Use the serialize library used in the Rust compiler with this crate.
+It is automatically published using the compiler repository at
+@url{https://www.github.com/rust-lang/rust}")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-rustc-demangle-0.1
(package
(name "rust-rustc-demangle")