summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-08-18 13:01:17 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-24 08:14:14 +0200
commit7dbd3a8e3e9492dbe7338886d2bc1e23f917933f (patch)
tree7325b0d9a353444ace70b33dcd1755c1edf24d75 /gnu
parentf22997b1a7e9ae480398c8963a5e28c6c5afa64e (diff)
downloadguix-patches-7dbd3a8e3e9492dbe7338886d2bc1e23f917933f.tar
guix-patches-7dbd3a8e3e9492dbe7338886d2bc1e23f917933f.tar.gz
gnu: mdadm: Fix cross-compilation.
* gnu/packages/linux.scm (mdadm)[arguments]: Search for coreutils in both native-inputs and inputs.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 351087e556..461c019d64 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3503,8 +3503,9 @@ MPEG-2 and audio over Linux IEEE 1394.")
#:phases
(modify-phases %standard-phases
(add-before 'build 'patch-program-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((coreutils (assoc-ref inputs "coreutils")))
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (let ((coreutils (assoc-ref (or native-inputs inputs)
+ "coreutils")))
(substitute* "udev-md-raid-arrays.rules"
(("/usr/bin/(readlink|basename)" all program)
(string-append coreutils "/bin/" program))))