summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-04 16:22:34 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-04 16:23:26 +0100
commit6b99bf8a6f5c594d667e5f4c76d5d4771b9c99c0 (patch)
tree116ee99f7ff2815442b704ed39c798a41a4bc96a /gnu
parent0beef79e442c9bab41b9a8b878abd906697c4f54 (diff)
downloadguix-patches-6b99bf8a6f5c594d667e5f4c76d5d4771b9c99c0.tar
guix-patches-6b99bf8a6f5c594d667e5f4c76d5d4771b9c99c0.tar.gz
gnu: Add r-fontquiver.
* gnu/packages/cran.scm (r-fontquiver): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index eafb916cb1..d4de1f1eef 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25937,3 +25937,26 @@ intended for the fontquiver package.")
"The Font Software may be sold as part of a larger software package but
no copy of one or more of the Font Software typefaces may be sold by
itself."))))
+
+(define-public r-fontquiver
+ (package
+ (name "r-fontquiver")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fontquiver" version))
+ (sha256
+ (base32
+ "0qv3i9hch7cygl9983s3w68wfh5qvym2jkm52pp06p6mq8a1i1wm"))))
+ (properties `((upstream-name . "fontquiver")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-fontbitstreamvera" ,r-fontbitstreamvera)
+ ("r-fontliberation" ,r-fontliberation)))
+ (home-page "https://cran.r-project.org/package=fontquiver")
+ (synopsis "Set of installed fonts")
+ (description
+ "This package provides a set of fonts. This is useful when you want to
+avoid system fonts to make sure your outputs are reproducible.")
+ (license license:gpl3)))