summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:27:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:43 +0200
commit697a5db6165ee84dc552260909913e24ff1817e8 (patch)
tree98cf163fd651cde2f9dabdf7cac8f49b34befcae /gnu
parent8f29ad5791f8f388ecfec40d9fc06a20e93d8441 (diff)
downloadguix-patches-697a5db6165ee84dc552260909913e24ff1817e8.tar
guix-patches-697a5db6165ee84dc552260909913e24ff1817e8.tar.gz
gnu: Add texlive-roundrect.
* gnu/packages/tex.scm (texlive-roundrect): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e11a0476c8..97b16029d6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6072,6 +6072,27 @@ expanding strokes. In @code{mftoeps}, Metafont writes PostScript code to
a log-file, from which it may be extracted by either TeX or AWK.")
(license license:public-domain)))
+(define-public texlive-roundrect
+ (package
+ (name "texlive-roundrect")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/roundrect/"
+ "metapost/roundrect/"
+ "source/metapost/roundrect/")
+ (base32
+ "0bx6xfr49rrcrnbyw917fab2qi0x29h66ip4nyhw6477815ic0wq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/roundrect")
+ (synopsis "MetaPost macros for configurable rounded rectangles")
+ (description
+ "The @code{roundrect} macros for MetaPost provide ways to produce rounded
+rectangles, which may or may not contain a title bar or text (the title bar
+may itself contain text).")
+ (license license:lppl1.3+)))
+
(define-public texlive-selinput
(package
(name "texlive-selinput")