summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-04 16:54:52 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-04 16:54:52 +0100
commit67a5590a662aa861d72cb3826f6994f2fa1b0d4d (patch)
treeb35ead5e5616e85502779bc1052e2821a6071a22 /gnu
parent74018fcb6c5471d20a70dc3a51daefe1e50916ad (diff)
downloadguix-patches-67a5590a662aa861d72cb3826f6994f2fa1b0d4d.tar
guix-patches-67a5590a662aa861d72cb3826f6994f2fa1b0d4d.tar.gz
gnu: Add r-fst.
* gnu/packages/cran.scm (r-fst): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5c5d0bb3f5..a60b2ea3d1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6526,6 +6526,31 @@ promises, but with a syntax that is idiomatic R.")
using the @code{snow} package.")
(license license:gpl2)))
+(define-public r-fst
+ (package
+ (name "r-fst")
+ (version "0.9.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fst" version))
+ (sha256
+ (base32
+ "0vwclzxww8mw9nnpyj29bn71mrr8jjg7ka03979h9rbzw6d9bjrr"))))
+ (properties `((upstream-name . "fst")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-rcpp" ,r-rcpp)))
+ (home-page "http://www.fstpackage.org")
+ (synopsis "Fast serialization of data frames")
+ (description
+ "The fst package for R provides a fast, easy and flexible way to
+serialize data frames. With access speeds of multiple GB/s, fst is
+specifically designed to unlock the potential of high speed solid state disks.
+Data frames stored in the fst format have full random access, both in column
+and rows. The fst format allows for random access of stored data and
+compression with the LZ4 and ZSTD compressors.")
+ (license license:agpl3)))
+
(define-public r-snowfall
(package
(name "r-snowfall")