summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-04 16:41:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-04 16:41:27 +0100
commit74018fcb6c5471d20a70dc3a51daefe1e50916ad (patch)
tree7d932cf1c71e746657e58b28888489e4e97da228 /gnu
parentbeb7e3f517f54319e5472703be746448190cc07c (diff)
downloadguix-patches-74018fcb6c5471d20a70dc3a51daefe1e50916ad.tar
guix-patches-74018fcb6c5471d20a70dc3a51daefe1e50916ad.tar.gz
gnu: Add r-rastervis.
* gnu/packages/cran.scm (r-rastervis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 00c870aec0..5c5d0bb3f5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6568,6 +6568,37 @@ user's computer should be used to save data, caches and logs. It is a port of
Python's @url{https://github.com/ActiveState/appdirs,Appdirs} to R.")
(license license:expat)))
+(define-public r-rastervis
+ (package
+ (name "r-rastervis")
+ (version "0.49")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rasterVis" version))
+ (sha256
+ (base32
+ "0d12h7xqcwy1wps6yya9nzfppbnsxpmbkqmy3a8pvxpg81l632kk"))))
+ (properties `((upstream-name . "rasterVis")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-hexbin" ,r-hexbin)
+ ("r-lattice" ,r-lattice)
+ ("r-latticeextra" ,r-latticeextra)
+ ("r-raster" ,r-raster)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-sp" ,r-sp)
+ ("r-viridislite" ,r-viridislite)
+ ("r-zoo" ,r-zoo)))
+ (home-page "https://oscarperpinan.github.io/rastervis/")
+ (synopsis "Visualization methods for raster data")
+ (description
+ "This package provides methods for enhanced visualization and interaction
+with raster data. It implements visualization methods for quantitative data
+and categorical data, both for univariate and multivariate rasters. It also
+provides methods to display spatiotemporal rasters, and vector fields.")
+ (license license:gpl3)))
+
(define-public r-rentrez
(package
(name "r-rentrez")