summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:27:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:44 +0200
commit6702f3808176e67f43151042182556515f3f0b36 (patch)
treeeb43583546f2cd34580b945d4c9ca742621b0539 /gnu
parent697a5db6165ee84dc552260909913e24ff1817e8 (diff)
downloadguix-patches-6702f3808176e67f43151042182556515f3f0b36.tar
guix-patches-6702f3808176e67f43151042182556515f3f0b36.tar.gz
gnu: Add texlive-shapes.
* gnu/packages/tex.scm (texlive-shapes): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 97b16029d6..cf40cad06d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6214,6 +6214,27 @@ user may consider the @code{dnaseq} as a rather more powerful alternative.")
(define-deprecated-package texlive-latex-seqsplit texlive-seqsplit)
+(define-public texlive-shapes
+ (package
+ (name "texlive-shapes")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/shapes/" "metapost/shapes/"
+ "source/metapost/shapes/")
+ (base32
+ "0q93ycxjzmvp73z92rc7vlzvmijbj2w1ldq709r9jflk044lsrh2")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/shapes")
+ (synopsis "Draw polygons, reentrant stars, and fractions in circles")
+ (description
+ "The shapes set of macros allows drawing regular polygons; their
+corresponding reentrant stars in all their variations; and fractionally filled
+circles (useful for visually demonstrating the nature of fractions) in
+MetaPost.")
+ (license license:lppl1.3+)))
+
(define-public texlive-showexpl
(package
(name "texlive-showexpl")