summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:10:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:35 +0200
commit6650b656ea188b809cb05b521d3ec6869c2fd602 (patch)
treea3866f35036ea7af541ea2d4811aa336f59417dd /gnu
parentbf5c92c6798fdb4688bf260258e4c6f110b4384b (diff)
downloadguix-patches-6650b656ea188b809cb05b521d3ec6869c2fd602.tar
guix-patches-6650b656ea188b809cb05b521d3ec6869c2fd602.tar.gz
gnu: Add texlive-feynmp-auto.
* gnu/packages/tex.scm (texlive-feynmp-auto): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f4be064c39..b02dcf8ff2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5174,6 +5174,28 @@ for diagrams in graph and similar theories, where the structure is
semi-algorithmically determined.")
(license license:gpl3+)))
+(define-public texlive-feynmp-auto
+ (package
+ (name "texlive-feynmp-auto")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/feynmp-auto/"
+ "source/latex/feynmp-auto/"
+ "tex/latex/feynmp-auto/")
+ (base32
+ "19ghfblv641ghak049v42wbqmh7pfadz0mrbkfbx2jr4bvf57rv2")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/feynmp-auto")
+ (synopsis "Automatic processing of @code{feynmp} graphics")
+ (description
+ "The package takes care of running Metapost on the output files produced
+by the @code{feynmp} package, so that the compiled pictures will be available
+in the next run of LaTeX. The package honours options that apply to
+@code{feynmp}.")
+ (license license:lppl1.3+)))
+
(define-public texlive-filemod
(package
(name "texlive-filemod")