summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2022-08-24 22:57:44 +0800
committerMarius Bakke <marius@gnu.org>2022-09-07 22:02:42 +0200
commit5c08546558f97e9ce665a83724b0e9d1751abac0 (patch)
tree2e6e144de8b15c7d5f20bae863e3edb96784c3ba /gnu
parent39647c97418f5527ed14f82144dac4172148fc4d (diff)
downloadguix-patches-5c08546558f97e9ce665a83724b0e9d1751abac0.tar
guix-patches-5c08546558f97e9ce665a83724b0e9d1751abac0.tar.gz
gnu: python-pyside-2: Use "this-package-input" instead of "assoc-ref".
* gnu/packages/qt.scm (python-pyside-2)[arguments]<#:configure-flags>: Use SEARCH-INPUT-FILE. <#:phases>: In phase "fix-qt-module-detection", use "this-package-input". Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm48
1 files changed, 25 insertions, 23 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d92f4ef852..2ebfe42abe 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -3880,8 +3880,8 @@ color-related widgets.")
#:configure-flags
#~(list "-DBUILD_TESTS=FALSE"
(string-append "-DPYTHON_EXECUTABLE="
- (assoc-ref %build-inputs "python")
- "/bin/python"))
+ (search-input-file %build-inputs
+ "/bin/python")))
#:modules '((guix build cmake-build-system)
(guix build utils)
(srfi srfi-1))
@@ -3890,33 +3890,35 @@ color-related widgets.")
(add-after 'unpack 'go-to-source-dir
(lambda _ (chdir "sources/pyside2") #t))
(add-after 'go-to-source-dir 'fix-qt-module-detection
- (lambda* (#:key inputs #:allow-other-keys)
+ (lambda _
;; Activate qt module support even if it not in the same
;; directory as qtbase.
(substitute* "../cmake_helpers/helpers.cmake"
(("\\(\"\\$\\{found_basepath\\}\" GREATER \"0\"\\)")
"true"))
;; Add include directories for qt modules.
- (let ((dirs (map (lambda (name)
- (string-append (assoc-ref inputs name)
- "/include/qt5"))
- '("qtdatavis3d"
- "qtdeclarative"
- "qtlocation"
- "qtmultimedia"
- "qtquickcontrols"
- "qtquickcontrols2"
- "qtscript"
- "qtscxml"
- "qtsensors"
- "qtspeech"
- "qtsvg"
- "qttools"
- "qtwebchannel"
- "qtwebengine"
- "qtwebsockets"
- "qtx11extras"
- "qtxmlpatterns"))))
+ (let ((dirs (map (lambda (path)
+ (string-append path "/include/qt5"))
+ (list
+ #$@(map (lambda (name)
+ (this-package-input name))
+ '("qtdatavis3d"
+ "qtdeclarative"
+ "qtlocation"
+ "qtmultimedia"
+ "qtquickcontrols"
+ "qtquickcontrols2"
+ "qtscript"
+ "qtscxml"
+ "qtsensors"
+ "qtspeech"
+ "qtsvg"
+ "qttools"
+ "qtwebchannel"
+ "qtwebengine"
+ "qtwebsockets"
+ "qtx11extras"
+ "qtxmlpatterns"))))))
(substitute* "cmake/Macros/PySideModules.cmake"
(("\\$\\{PATH_SEP\\}\\$\\{core_includes\\}" all)
(fold (lambda (dir paths)