summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2022-08-24 22:54:46 +0800
committerMarius Bakke <marius@gnu.org>2022-09-07 22:02:41 +0200
commit39647c97418f5527ed14f82144dac4172148fc4d (patch)
tree9ef28be293f03f59bec3ac43965f9aee47f64b31 /gnu
parent00652ce2eef7051c277d8f53c4c43acc4eb98b34 (diff)
downloadguix-patches-39647c97418f5527ed14f82144dac4172148fc4d.tar
guix-patches-39647c97418f5527ed14f82144dac4172148fc4d.tar.gz
gnu: python-pyside-2: Clarify the package inputs.
The module "PySide.PyQtUiTools" depends on "qttools-5", it should be an input, not a native input. libxml2, libxslt, clang-toolchain is only used by python-shiboken-2. cmake-minimal is not used. * gnu/packages/qt.scm (python-pyside-2): [inputs]: Remove libxml2, libxslt, clang-toolchain. Add qttools-5. [native-inputs]: Remove cmake-minimal, qttools-5. [arguments]<#:phases>: Remove phase "set-clang-dir". Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d496f69107..d92f4ef852 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -3851,10 +3851,7 @@ color-related widgets.")
(source (package-source python-shiboken-2))
(build-system cmake-build-system)
(inputs
- (list libxml2
- libxslt
- clang-toolchain
- qtbase-5
+ (list qtbase-5
qtdatavis3d
qtdeclarative-5
qtlocation
@@ -3866,6 +3863,7 @@ color-related widgets.")
qtsensors
qtspeech
qtsvg-5
+ qttools-5
qtwebchannel-5
qtwebengine-5
qtwebsockets-5
@@ -3874,7 +3872,7 @@ color-related widgets.")
(propagated-inputs
(list python-shiboken-2))
(native-inputs
- (list cmake-minimal python-wrapper qttools-5 which))
+ (list python-wrapper))
(arguments
(list
#:tests? #f
@@ -3928,12 +3926,7 @@ color-related widgets.")
(setenv "CXXFLAGS" (fold (lambda (dir paths)
(string-append paths " -I" dir))
""
- dirs)))))
- (add-before 'configure 'set-clang-dir
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((clang (assoc-ref inputs "clang-toolchain")))
- (setenv "CLANG_INSTALL_DIR" clang)
- #t))))))
+ dirs))))))))
(home-page "https://wiki.qt.io/Qt_for_Python")
(synopsis
"The Qt for Python product enables the use of Qt5 APIs in Python applications")