summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:28:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:44 +0200
commit5b5f5a2f977da9af91f26fa08238f91f7dd89dc9 (patch)
treeeaa454875d02cae3f07f76bfdad52515295d6201 /gnu
parent6702f3808176e67f43151042182556515f3f0b36 (diff)
downloadguix-patches-5b5f5a2f977da9af91f26fa08238f91f7dd89dc9.tar
guix-patches-5b5f5a2f977da9af91f26fa08238f91f7dd89dc9.tar.gz
gnu: Add texlive-slideshow.
* gnu/packages/tex.scm (texlive-slideshow): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cf40cad06d..d6595a3ad5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6254,6 +6254,25 @@ MetaPost.")
result in the same document.")
(license license:lppl1.2+)))
+(define-public texlive-slideshow
+ (package
+ (name "texlive-slideshow")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/slideshow/"
+ "metapost/slideshow/")
+ (base32
+ "07r58whn61nyxj0cldzf9bbwhh0kc72d6708ldf03q7sbf5zi37s")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/slideshow")
+ (synopsis "Generate slideshow with MetaPost")
+ (description
+ "The package provides a means of creating presentations in MetaPost,
+without intervention from other utilities (except a distiller).")
+ (license (license:fsf-free "file://metapost/slideshow/slideshow.mp"))))
+
(define-public texlive-stackengine
(package
(name "texlive-stackengine")