summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:12:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:36 +0200
commit5a05a146deea829a921b78cdfd8a52692ce956a9 (patch)
tree43bb98baa5c4ac73ad81331c7fda01102789dd5a /gnu
parentaff83a15a7f1f9884092ca2b907ab59b6089d280 (diff)
downloadguix-patches-5a05a146deea829a921b78cdfd8a52692ce956a9.tar
guix-patches-5a05a146deea829a921b78cdfd8a52692ce956a9.tar.gz
gnu: Add texlive-gmp.
* gnu/packages/tex.scm (texlive-gmp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 58ea41ff3e..b0420d3779 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5363,6 +5363,27 @@ yet reflected in the package's or class's code. The file
meant to be loaded during format generation and not by the user.")
(license license:lppl1.3c)))
+(define-public texlive-gmp
+ (package
+ (name "texlive-gmp")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/gmp/" "source/latex/gmp/"
+ "tex/latex/gmp/")
+ (base32
+ "1zvl80wjg4xsika0p0v6jskrwdpy3n7qbfvbg76qbzzpc03n6x6a")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/gmp")
+ (synopsis "Enable integration between MetaPost pictures and LaTeX")
+ (description
+ "The package allows integration between MetaPost pictures and LaTeX.
+The main feature is that passing parameters to the MetaPost pictures is
+possible and the picture code can be put inside arguments to commands,
+including @code{\\newcommand}.")
+ (license license:lppl1.3+)))
+
(define-public texlive-ifplatform
(package
(name "texlive-ifplatform")