summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2022-08-25 20:17:55 +0200
committerMarius Bakke <marius@gnu.org>2022-08-29 18:22:58 +0200
commit5831155175614726685edab7efa60ce48e4da1f5 (patch)
treeca5de9fa00d8f5fdb87de637231c4e1b7dee139f /gnu
parent52aa21cc9a15cdbbae1c72b8fd28adeb66791a9b (diff)
downloadguix-patches-5831155175614726685edab7efa60ce48e4da1f5.tar
guix-patches-5831155175614726685edab7efa60ce48e4da1f5.tar.gz
gnu: snakemake-7: Fix cluster execution bug
* gnu/packages/python-xyz.scm (snakemake-7)[arguments]: Revise the patch for the cluster execution script Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 30645fc4a0..0accf918ee 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9739,15 +9739,14 @@ Python style, together with a fast and comfortable execution environment.")
;; For cluster execution Snakemake will call Python. Since there is
;; no suitable GUIX_PYTHONPATH set, cluster execution will fail. We
;; fix this by calling the snakemake wrapper instead.
-
- ;; XXX: There is another instance of sys.executable on line 692, but
- ;; it is not clear how to patch it.
(add-after 'unpack 'call-wrapper-not-wrapped-snakemake
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "snakemake/executors/__init__.py"
- (("\\{sys.executable\\} -m snakemake")
- (string-append (assoc-ref outputs "out")
- "/bin/snakemake")))))
+ (("self\\.get_python_executable\\(\\),")
+ "")
+ (("\"-m snakemake\"")
+ (string-append "\"" (assoc-ref outputs "out")
+ "/bin/snakemake" "\"")))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?