summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-04-22 10:31:55 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-04-22 10:36:51 +0200
commit5763eba94cccc4019cb07b0cac6c16132c741e11 (patch)
treed3cdcddd823d2944bb7536fdd9b22a3b5a213213 /gnu
parent3de01371dc0c5fb0847d8ad64bc508f77396f56b (diff)
downloadguix-patches-5763eba94cccc4019cb07b0cac6c16132c741e11.tar
guix-patches-5763eba94cccc4019cb07b0cac6c16132c741e11.tar.gz
gnu: Add cl-weir.
* gnu/packages/lisp-xyz.scm (cl-weir, ecl-weir, sbcl-weir): New variables. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 666e62a4ce..955cbcfeb4 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16066,3 +16066,54 @@ handling the accessing of files on the underlying system however.")
(define-public cl-pathname-utils
(sbcl-package->cl-source-package sbcl-pathname-utils))
+
+(define-public sbcl-weir
+ (let ((commit "beb4f6f47f0538d2c6d73b1d3c9d7f58ac8aa0e9")
+ (revision "1"))
+ (package
+ (name "sbcl-weir")
+ (version (git-version "4.9.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/inconvergent/weir")
+ (commit commit)))
+ (file-name (git-file-name "weir" version))
+ (sha256
+ (base32 "1vm10kb51g4ba2nl5yixswkk47vwqgwqdlz5031xfff8h9z2a6ad"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ (for-each make-file-writable
+ (find-files "test/data/")))))))
+ (inputs
+ `(("alexandira" ,sbcl-alexandria)
+ ("cl-json" ,sbcl-cl-json)
+ ("cl-svg" ,sbcl-cl-svg)
+ ("inferior-shell" ,sbcl-inferior-shell)
+ ("lparallel" ,sbcl-lparallel)
+ ("png" ,sbcl-png)
+ ("split-sequence" ,sbcl-split-sequence)
+ ("zpng" ,sbcl-zpng)))
+ (home-page "https://github.com/inconvergent/weir")
+ (synopsis "System for making generative systems")
+ (description
+ "This package provides a Common Lisp system for generating 2d and 3d
+vector artworks with SVG and PNG export format.")
+ (license license:expat))))
+
+(define-public ecl-weir
+ (let ((pkg (sbcl-package->ecl-package sbcl-weir)))
+ (package
+ (inherit pkg)
+ (arguments
+ (substitute-keyword-arguments (package-arguments pkg)
+ ;; FIXME: 17 tests out of 128 are failing on ECL.
+ ((#:tests? _ #f) #f))))))
+
+(define-public cl-weir
+ (sbcl-package->cl-source-package sbcl-weir))