summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-04-21 22:20:07 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-04-22 10:36:51 +0200
commit3de01371dc0c5fb0847d8ad64bc508f77396f56b (patch)
tree0672083c41a1b1f660ac347522f9c5e34c4a024b /gnu
parent296e230896babea785bb0f7cd34ab10645f146e8 (diff)
downloadguix-patches-3de01371dc0c5fb0847d8ad64bc508f77396f56b.tar
guix-patches-3de01371dc0c5fb0847d8ad64bc508f77396f56b.tar.gz
gnu: Add cl-pathname-utils.
* gnu/packages/lisp-xyz.scm (sbcl-pathname-utils, cl-pathname-utils, ecl-pathname-utils): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0e82f8fc2c..666e62a4ce 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16034,3 +16034,35 @@ lQuery.")
(define-public cl-clip
(sbcl-package->cl-source-package sbcl-clip))
+
+(define-public sbcl-pathname-utils
+ (let ((commit "70f517e44e13a38e0c8f296613236376d679fa8f")
+ (revision "1"))
+ (package
+ (name "sbcl-pathname-utils")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/pathname-utils")
+ (commit commit)))
+ (file-name (git-file-name "pathname-utils" version))
+ (sha256
+ (base32 "1zm4bf6gajpgmhr7zwf7600zlaf8fs1fcyzabqsh2ma2crkgqdxq"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("parachute" ,sbcl-parachute)))
+ (home-page "https://shinmera.github.io/pathname-utils/")
+ (synopsis "Collection of utilities to help with pathname operations")
+ (description
+ "This package provides a Common Lisp system a with collection of common
+tests and operations to help handling pathnames. It does not actually deal in
+handling the accessing of files on the underlying system however.")
+ (license license:zlib))))
+
+(define-public ecl-pathname-utils
+ (sbcl-package->ecl-package sbcl-pathname-utils))
+
+(define-public cl-pathname-utils
+ (sbcl-package->cl-source-package sbcl-pathname-utils))