summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-09-23 16:13:43 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-06 18:02:48 +0200
commit5157edd8854c895dfb78f6cf49e906e49745ca8a (patch)
tree0fa974aad0f45cfb666841878faea2415b4e7d63 /gnu
parent81bc4533aa1d7d81472c1d8d9f697ba2a9c9cbf9 (diff)
downloadguix-patches-5157edd8854c895dfb78f6cf49e906e49745ca8a.tar
guix-patches-5157edd8854c895dfb78f6cf49e906e49745ca8a.tar.gz
gnu: perf: Treat kernel headers as system headers.
* gnu/packages/linux.scm (perf)[arguments]: Instead of disabling -Werror, set C_INCLUDE_PATH.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6664620c04..d7e3d7ef7f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3091,15 +3091,16 @@ in a digital read-out.")
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key inputs #:allow-other-keys)
- ;; Don't build with '-Werror', really.
- (substitute* "tools/lib/bpf/Makefile"
- (("-Werror") ""))
-
(setenv "SHELL_PATH" (which "bash"))
(chdir "tools/perf")
#t)))
#:make-flags (list (string-append "prefix="
(assoc-ref %outputs "out"))
+ ;; Make sure the kernel headers are treated as system
+ ;; headers to suppress warnings from those.
+ (string-append "C_INCLUDE_PATH="
+ (assoc-ref %build-inputs "kernel-headers")
+ "/include")
"WERROR=0"
;; By default, 'config/Makefile' uses lib64 on