summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6664620c04..d7e3d7ef7f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3091,15 +3091,16 @@ in a digital read-out.")
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key inputs #:allow-other-keys)
- ;; Don't build with '-Werror', really.
- (substitute* "tools/lib/bpf/Makefile"
- (("-Werror") ""))
-
(setenv "SHELL_PATH" (which "bash"))
(chdir "tools/perf")
#t)))
#:make-flags (list (string-append "prefix="
(assoc-ref %outputs "out"))
+ ;; Make sure the kernel headers are treated as system
+ ;; headers to suppress warnings from those.
+ (string-append "C_INCLUDE_PATH="
+ (assoc-ref %build-inputs "kernel-headers")
+ "/include")
"WERROR=0"
;; By default, 'config/Makefile' uses lib64 on