summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-04-13 13:14:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-04-13 13:41:18 +0200
commit4cb6120584e6d19ca8ac5756c48ac3cca660145d (patch)
tree5aa6f8727830d6f0f3874cc877a94dd884cfa20b /gnu
parenta26dd2e282c10224e6512fa09f8badb205c2ad82 (diff)
downloadguix-patches-4cb6120584e6d19ca8ac5756c48ac3cca660145d.tar
guix-patches-4cb6120584e6d19ca8ac5756c48ac3cca660145d.tar.gz
gnu: Add python-jupyterlab-widgets.
* gnu/packages/jupyter.scm (python-jupyterlab-widgets): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/jupyter.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 796a8dc912..52869dbeeb 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -242,6 +242,27 @@ Jupyter Python packages that require a pre-build step that may include
JavaScript build steps.")
(license license:bsd-3)))
+(define-public python-jupyterlab-widgets
+ (package
+ (name "python-jupyterlab-widgets")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jupyterlab_widgets" version))
+ (sha256
+ (base32
+ "0y7vhhas3qndiypcpcfnhrj9n92v2w4hdc86nn620s9h9nl2j6jw"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-jupyter-packaging" ,python-jupyter-packaging)
+ ("python-setuptools" ,python-setuptools)))
+ (home-page "https://github.com/jupyter-widgets/ipywidgets")
+ (synopsis "Interactive widgets for Jupyter Notebooks")
+ (description "ipywidgets, also known as jupyter-widgets or simply widgets,
+are interactive HTML widgets for Jupyter notebooks and the IPython kernel.")
+ (license license:bsd-3)))
+
(define-public python-nbclient
(package
(name "python-nbclient")