summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-04-13 13:14:37 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-04-13 13:41:18 +0200
commita26dd2e282c10224e6512fa09f8badb205c2ad82 (patch)
tree5d3ca74dbe21680fc803763578225eaff77c527f /gnu
parentc00996fdbe39d5b3ac4dc63eda45e7eb5b13e0f4 (diff)
downloadguix-patches-a26dd2e282c10224e6512fa09f8badb205c2ad82.tar
guix-patches-a26dd2e282c10224e6512fa09f8badb205c2ad82.tar.gz
gnu: Add python-jupyter-packaging.
* gnu/packages/jupyter.scm (python-jupyter-packaging): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/jupyter.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 6db61f398b..796a8dc912 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -211,6 +211,37 @@ alternative Python kernel for Jupyter.")
the JupyterLab CSS variables.")
(license license:bsd-3)))
+(define-public python-jupyter-packaging
+ (package
+ (name "python-jupyter-packaging")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jupyter_packaging" version))
+ (sha256
+ (base32
+ "0r015c0m713d19asmpimsw6bk2sqv2lpd2nccgjzjdj5h1crg0bg"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-deprecation" ,python-deprecation)
+ ("python-packaging" ,python-packaging)
+ ("python-setuptools" ,python-setuptools)
+ ("python-tomlkit" ,python-tomlkit)
+ ("python-wheel" ,python-wheel)))
+ (native-inputs
+ `(("python-pypa-build" ,python-pypa-build)
+ ("python-coverage" ,python-coverage)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-mock" ,python-pytest-mock)))
+ (home-page "https://jupyter.org")
+ (synopsis "Jupyter packaging utilities")
+ (description "This package provides tools to help build and install
+Jupyter Python packages that require a pre-build step that may include
+JavaScript build steps.")
+ (license license:bsd-3)))
+
(define-public python-nbclient
(package
(name "python-nbclient")