summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:11:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:35 +0200
commit4c9cff98842fb22ba75ab65445253f6db6f71ef9 (patch)
treef58a0bed16c175757de25eaff190ea8ad59e2a20 /gnu
parent6650b656ea188b809cb05b521d3ec6869c2fd602 (diff)
downloadguix-patches-4c9cff98842fb22ba75ab65445253f6db6f71ef9.tar
guix-patches-4c9cff98842fb22ba75ab65445253f6db6f71ef9.tar.gz
gnu: Add texlive-fiziko.
* gnu/packages/tex.scm (texlive-fiziko): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b02dcf8ff2..7f4d99a592 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5248,6 +5248,27 @@ that column has any marks at all; keep two column floats like @code{figure*}
in sequence with single column floats like figure.")
(license license:lppl)))
+(define-public texlive-fiziko
+ (package
+ (name "texlive-fiziko")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin name version
+ (list "doc/metapost/fiziko/" "metapost/fiziko/")
+ (base32
+ "160iqgm4f7imnj89gj4822xv5wnnxf336k261v52h6sd0lhnhany")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/fiziko")
+ (synopsis "MetaPost library for physics textbook illustrations")
+ (description
+ "This MetaPost library was initially written to automate some elements of
+black and white illustrations for a physics textbook. It provides functions
+to draw things like lines of variable width, shaded spheres, and tubes of
+different kinds, which can be used to produce images of a variety of objects.
+The library also contains functions to draw some objects constructed from
+these primitives.")
+ (license (list license:gpl3+ license:cc-by-sa4.0))))
+
(define-public texlive-hanging
(package
(name "texlive-hanging")