summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:06:17 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:32 +0200
commit40ba14a0e06667dbccec813a6978d7024dbb5768 (patch)
tree677c0e9f1a427499bb00fd6f7556cefb511c346b /gnu
parentf08a918e2b26ae183334f24b52ffcff77c138ee0 (diff)
downloadguix-patches-40ba14a0e06667dbccec813a6978d7024dbb5768.tar
guix-patches-40ba14a0e06667dbccec813a6978d7024dbb5768.tar.gz
gnu: Add texlive-drv.
* gnu/packages/tex.scm (texlive-drv): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index eb12a2764d..49f3496453 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4873,6 +4873,25 @@ implementation is output device independent, and made very simple by relying
on @code{everypage}.")
(license license:lppl1.3+)))
+(define-public texlive-drv
+ (package
+ (name "texlive-drv")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/drv/" "metapost/drv/")
+ (base32
+ "0vjc9x9xa50zzzc3m2csj9x0gqwcamhyqz1xkdbkqwkcy8rfpnlh")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/drv")
+ (synopsis "Derivation trees with MetaPost")
+ (description
+ "This package provides a set of MetaPost macros for typesetting
+derivation trees (such as used in sequent calculus, type inference,
+programming language semantics...).")
+ (license license:lppl)))
+
(define-public texlive-enctex
(package
(name "texlive-enctex")