summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorguy fleury iteriteka <hoonandon@gmail.com>2020-07-08 12:52:18 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-07-08 12:52:18 +0200
commit35ddc92a27adfbf656a89bc48c68d5b5762a046a (patch)
tree87d3053649052f9dd8826eea7f507a4abd36bbb7 /gnu
parentc19973280fb8a5b3419e0ebdbd1ce7e1c09559df (diff)
downloadguix-patches-35ddc92a27adfbf656a89bc48c68d5b5762a046a.tar
guix-patches-35ddc92a27adfbf656a89bc48c68d5b5762a046a.tar.gz
gnu: Add python-cli-helpers.
* gnu/packages/python-xyz.scm (python-cli-helpers): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c4e5002073..98db6d9e51 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2392,6 +2392,36 @@ files.")
(define-public python2-pyld
(package-with-python2 python-pyld))
+(define-public python-cli-helpers
+ (package
+ (name "python-cli-helpers")
+ (version "2.0.1")
+ (source
+ (origin
+ ;; There's no source tarball on PyPI.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dbcli/cli_helpers.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bg2iw9l5dip0kbs00hajdk2v18wvhssbnq8hdf71278qf0wks5l"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-wcwidth" ,python-wcwidth)
+ ("python-configobj" ,python-configobj)
+ ("python-tabulate" ,python-tabulate)
+ ("python-terminaltables" ,python-terminaltables)))
+ (home-page "https://github.com/dbcli/cli_helpers")
+ (synopsis "Helpers for building command-line apps")
+ (description
+ "CLI Helpers is a Python package that makes it easy to perform common
+tasks when building command-line apps. It's a helper library for command-line
+interfaces.")
+ (license license:bsd-3)))
+
(define-public python-click
(package
(name "python-click")