summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorguy fleury iteriteka <gfleury@disroot.org>2020-07-04 21:31:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-07-08 12:50:15 +0200
commitc19973280fb8a5b3419e0ebdbd1ce7e1c09559df (patch)
tree86a651fc1799d08114134c1e45bd15eff669e4d4 /gnu
parent560540f005cf83b713569cb3a959b547f3840bca (diff)
downloadguix-patches-c19973280fb8a5b3419e0ebdbd1ce7e1c09559df.tar
guix-patches-c19973280fb8a5b3419e0ebdbd1ce7e1c09559df.tar.gz
gnu: Add python-terminaltables
* gnu/packages/python-xyz.scm(python-terminaltables): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 55860fa57f..c4e5002073 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -82,6 +82,7 @@
;;; Copyright © 2020 Yuval Kogman <nothingmuch@woobling.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8831,6 +8832,26 @@ a hash value.")
(define-public python2-termcolor
(package-with-python2 python-termcolor))
+(define-public python-terminaltables
+ (package
+ (name "python-terminaltables")
+ (version "3.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "terminaltables" version))
+ (sha256
+ (base32
+ "109vhldk6nv1z3hzp4dyqf6rjvlhl0y2k5k7qcm9fcrq5swhxszk"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/Robpol86/terminaltables")
+ (synopsis
+ "Generate simple tables in terminals from a nested list of strings")
+ (description
+ "This package makes it easy to draw tables in terminal/console
+applications from a list of lists of strings. It supports multi-line rows.")
+ (license license:expat)))
+
(define-public python-libarchive-c
(package
(name "python-libarchive-c")