summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:29:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:45 +0200
commit332cf3df1a32a9df1e1101d0d8e7f7f971e14f77 (patch)
tree220d30391a76c4130e32cfdc8d356d9ff2aac1e8 /gnu
parentf534bbcb722f7bc1103ea1c2bf7b9ebc08f006c7 (diff)
downloadguix-patches-332cf3df1a32a9df1e1101d0d8e7f7f971e14f77.tar
guix-patches-332cf3df1a32a9df1e1101d0d8e7f7f971e14f77.tar.gz
gnu: Add texlive-textpath.
* gnu/packages/tex.scm (texlive-textpath): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6eda17875b..6833fa4ae7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6333,6 +6333,26 @@ of which make use of the @code{stackengine} core.")
"The package provides macros for drawing Chinese and Japanese abaci.")
(license license:lppl)))
+(define-public texlive-textpath
+ (package
+ (name "texlive-textpath")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/textpath/"
+ "metapost/textpath/" "tex/latex/textpath/")
+ (base32
+ "07g7n0hjsvsk0cibprpqid43vvljjzagap07zbp2kirkiv7yq3k0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/textpath")
+ (synopsis "Setting text along a path with MetaPost")
+ (description
+ "This MetaPost package provides macros to typeset text along a free path
+with the help of LaTeX, thereby preserving kerning and allowing for 8-bit
+input (accented characters).")
+ (license license:lppl)))
+
(define-public texlive-tocloft
(package
(name "texlive-tocloft")