summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:29:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:45 +0200
commitf534bbcb722f7bc1103ea1c2bf7b9ebc08f006c7 (patch)
tree40b53f352ce55b78800b6e542491c4dc6404831e /gnu
parent55019ebccc8fe51a5a2e8733642f2c0458a58fb2 (diff)
downloadguix-patches-f534bbcb722f7bc1103ea1c2bf7b9ebc08f006c7.tar
guix-patches-f534bbcb722f7bc1103ea1c2bf7b9ebc08f006c7.tar.gz
gnu: Add texlive-suanpan.
* gnu/packages/tex.scm (texlive-suanpan): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3729e79db8..6eda17875b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6316,6 +6316,23 @@ of which make use of the @code{stackengine} core.")
(define-deprecated-package texlive-latex-stackengine texlive-stackengine)
+(define-public texlive-suanpan
+ (package
+ (name "texlive-suanpan")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/suanpan/" "metapost/suanpan/")
+ (base32
+ "1ddhk8d98bc4l2xbx5w6kaynl4n125nnv4hadfp5s19vwcc6slqv")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/suanpan")
+ (synopsis "MetaPost macros for drawing Chinese and Japanese abaci")
+ (description
+ "The package provides macros for drawing Chinese and Japanese abaci.")
+ (license license:lppl)))
+
(define-public texlive-tocloft
(package
(name "texlive-tocloft")