summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:09:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:34 +0200
commit09e0b7fff5ec577e83bb5b2ab69391ecab256089 (patch)
treed067ada8b343d87e643bef42bbc248549bf67b35 /gnu
parentb93ad894503426d9439ac5c22237c6042ba9e8cf (diff)
downloadguix-patches-09e0b7fff5ec577e83bb5b2ab69391ecab256089.tar
guix-patches-09e0b7fff5ec577e83bb5b2ab69391ecab256089.tar.gz
gnu: Add texlive-exteps.
* gnu/packages/tex.scm (texlive-exteps): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3c6b389363..8494776ff4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5112,6 +5112,25 @@ Shlaer-Mellor, and NIAM diagrams. The package may also be used to create UML
and most other Box-Line-Annotation charts, but not Gantt charts directly.")
(license license:lppl)))
+(define-public texlive-exteps
+ (package
+ (name "texlive-exteps")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/exteps/" "metapost/exteps/")
+ (base32
+ "1mmlmcjn8fk16y14p3q6xfmkcc75vcykblgcyzapzxd1nzy51ak7")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/exteps")
+ (synopsis "Include EPS figures in MetaPost")
+ (description
+ "Exteps is a module for including external EPS figures into MetaPost
+figures. It is written entirely in MetaPost, and does not therefore require
+any post processing of the MetaPost output.")
+ (license license:gpl3+)))
+
(define-public texlive-filemod
(package
(name "texlive-filemod")