summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:04:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:31 +0200
commit15e928f5e3d78e46eedd25cd1e9e2a7440f917f6 (patch)
tree8f4a4ce281f7dbccf4232dcfea24b2af089d556e /gnu
parentb853941a622e6c72dd1dcc6c79db2f9a570d523b (diff)
downloadguix-patches-15e928f5e3d78e46eedd25cd1e9e2a7440f917f6.tar
guix-patches-15e928f5e3d78e46eedd25cd1e9e2a7440f917f6.tar.gz
gnu: Add texlive-automata.
* gnu/packages/tex.scm (texlive-automata): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1a53979f82..e3c794163d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2613,6 +2613,28 @@ the @file{.aux} file.")
(define-deprecated-package texlive-latex-atveryend texlive-atveryend)
+(define-public texlive-automata
+ (package
+ (name "texlive-automata")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/automata/"
+ "metapost/automata/")
+ (base32
+ "0y02wp1w2jkhrxanz7r699kr08bmbfn0h0xaxj3zh4xj9745d7d7")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/automata")
+ (synopsis "Finite state machines, graphs and trees in MetaPost")
+ (description
+ "The package offers a collection of macros for MetaPost to make easier to
+draw finite-state machines, automata, labelled graphs, etc. The user defines
+nodes, which may be isolated or arranged into matrices or trees; edges connect
+pairs of nodes through arbitrary paths. Parameters, that specify the shapes
+of nodes and the styles of edges, may be adjusted.")
+ (license license:lppl)))
+
(define-public texlive-auxhook
(package
(name "texlive-auxhook")